OSPFv2
Configuración de OSPFv2.
"Topología de red Implementada"
Descripción: En la siguiente imagen se muestran 3 Router Cisco ISR S4300 conectados directamente usando el protocolo de enrutamiento OSPFv2.
¿Qué es OSPF?:
OSPF, o Protocolo de Enrutamiento de Estado de Enlace (Open Shortest Path First), es un protocolo de enrutamiento interior utilizado en redes de computadoras para determinar las rutas más eficientes para el envío de paquetes de datos. Fue diseñado para funcionar en redes IP y es uno de los protocolos de enrutamiento más ampliamente utilizados en redes empresariales y proveedores de servicios.
Configuración de OSPFv2
#Configurar las Interfaces#
R1>enable
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface GigabitEthernet0/0/0
R1(config-if)#description ENLACE LAN
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial0/1/0
R1(config-if)#description ENLACE HACIA R2
R1(config-if)#ip address 128.10.10.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#interface Serial0/1/1
R1(config-if)#description ENLACE HACIA R3
R1(config-if)#ip address 128.30.30.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
R1(config-if)#exit
#Configurar OSPFv2#
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#passive-interface GigabitEthernet0/0/0
R1(config-router)#network 192.168.0.0 0.0.0.255 area 1
R1(config-router)#network 128.10.10.0 0.0.0.3 area 0
R1(config-router)#network 128.30.30.0 0.0.0.3 area 0
R1(config-router)#exit
R1(config)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up
R1(config)#
#Configurar las Interfaces#
R2>enable
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface GigabitEthernet0/0/0
R2(config-if)#description ENLACE LAN
R2(config-if)#ip address 172.16.0.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface Serial0/1/0
R2(config-if)#ip address 128.20.20.1 255.255.255.252
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R2(config-if)#exit
R2(config)#interface Serial0/1/1
R2(config-if)#description ENLACE HACIA R1
R2(config-if)#ip address 128.10.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
#Configurar OSPFv2#
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#passive-interface GigabitEthernet0/0/0
R2(config-router)#network 172.16.0.0 0.0.0.255 area 2
R2(config-router)#network 128.10.10.0 0.0.0.3 area 0
R2(config-router)#network 128.20.20.0 0.0.0.3 area 0
R2(config-router)#exit
R2(config)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up
03:16:38: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/1/1 from LOADING to FULL, Loading Done
R2(config)#
#Configurar las Interfaces#
R3>enable
R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#interface GigabitEthernet0/0/0
R3(config-if)#description ENLACE LAN
R3(config-if)#ip address 10.10.0.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface Serial0/1/0
R3(config-if)#description ENLACE HACIA R2
R3(config-if)#ip address 128.20.20.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface Serial0/1/1
R3(config-if)#description ENLACE R1
R3(config-if)#ip address 128.30.30.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
#Configurar OSPFv2#
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#passive-interface GigabitEthernet0/0/0
R3(config-router)#network 10.10.0.0 0.0.0.255 area 3
R3(config-router)#network 128.30.30.0 0.0.0.3 area 0
R3(config-router)#network 128.20.20.0 0.0.0.3 area 0
R3(config-router)#exit
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
03:17:15: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/1/1 from LOADING to FULL, Loading Done
03:17:15: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/1/0 from LOADING to FULL, Loading Done
R3(config)#
#Verificar procesos OSPF 1 en R1, R2 y R3#
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:31 128.10.10.2 Serial0/1/0
3.3.3.3 0 FULL/ - 00:00:31 128.30.30.2 Serial0/1/1
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:00:33 128.20.20.2 Serial0/1/0
1.1.1.1 0 FULL/ - 00:00:36 128.10.10.1 Serial0/1/1
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:31 128.20.20.1 Serial0/1/0
1.1.1.1 0 FULL/ - 00:00:31 128.30.30.1 Serial0/1/1
Tabla de Direccionamiento
Prueba de Conectividad de PC3 a PC1 y PC2
Descarga aquí la topología (OSPFv2.pkt)
Comentarios
Publicar un comentario